normal_post in some advice needed in Electrical & Audio Author Topic: some advice needed  (Read 438 times)

Offline Plumcrazy72

  • Trade Count: (0)
  • Leaning Tower of Power
  • *
  • Location: Milverton
  • index in some advice needed in Electrical & Audio
  • Posts: 100
  • Credits: 850
    • Share Post
xx in some advice needed in Electrical & Audio
some advice needed
« on: October 11, 2018, 07:35:59 AM »
I have been having the worst luck with finding a good neutral safety switch. My original started acting up so i tried replacing it. I have went through 8 NSS now with not one worthy of calling good. They either leak in odd spots, or don't work at all. The one i have now doesn't turn on my reverse lights but at least isn't leaking. I had one in that did everything it should but leaked between the center rubber area and the casing. So i was able to find an old original a guy give to me to try. I put it in and doesn't work, no reverse lights, would start in any gear etc (the worst one i've tried so far). When i had it on a hoist and moved the shifter through the gears i thought i could see the lights give a flicker, after finding out the old original was worse than the one i had in there i switched it back out. I found that i now have no turn signals and no break lights, my 4 way flashers do work, and all my running lights work as well. Could something have shorted out in the old original NSS? I checked fuse #3 and its fine, would it be my flasher relay? any input is welcome as this is starting to make me  :pullinghair: Thanks

Linkback: https://forum.e-bodies.org/electrical-and-audio/11/some-advice-needed/8742/
1972 340 PCP
2012 Ram 1500 Outdoorsman
2015 Dodge Journey Crossroad

Offline Chryco Psycho

  • Global Moderator
  • Trade Count: (0)
  • E-Body Wizard
  • *****
  • Location: Coronado Panama
  • index in some advice needed in Electrical & Audio
  • Posts: 6617
  • Credits: 15260
  • Challenger ... You'll wish you hadn't !!
    • Share Post
xx in some advice needed in Electrical & Audio
Re: some advice needed
« Reply #1 on: October 11, 2018, 08:58:31 AM »
You have separate flashers for 4 way & turn signal so it is possible , but that will nto affect the brake lights .
the brake lights could be a bad turn signal switch or a bad brake light switch , you can trace power through the brake light switch up to the column  . Often if up put pressure toward you on the turn signal arm it may connect & work if so the problem for brake & Turn is in the TS switch
 
1-190417082201 in some advice needed in Electrical & Audio

Offline dodj

  • Trade Count: (1)
  • Big Block
  • ***
  • Location: Thunder Bay
  • index in some advice needed in Electrical & Audio
  • Posts: 649
  • Credits: 3070
    • Share Post
xx in some advice needed in Electrical & Audio
Re: some advice needed
« Reply #2 on: October 11, 2018, 09:39:13 AM »
If you went through 8 NSS switches I would start to suspect the lever in the transmission. Did the ones that leaked function properly otherwise? If they did then trans lever would be fine. There are two different length NSS switches out there, take a look at your collection and see if they are all the same. Then I would bench test the switch. Centre pin should have continuity to the 'nub' on the side of the switch that goes into the trans. The outer two pins should have continuity when the switch is activated (depressed). When you find one that checks out electrically, Install in the trans and check that the centre pin has continuity to the case of the trans when in park or neutral. If it doesn't, maybe something is in the way of screwing the switch in all the way? Maybe two or three gaskets?
For the reverse lights, put it in reverse and see if the outer pins have continuity. If you do, the switch /trans is ok and the issue is in the wiring to the reverse lights, or power to the switch for the reverse lights.
If you don't have continuity, and it bench tested ok, it is a matter of switch seating depth, or the plastic shroud may have broken in the trans - which would give the car the ability to start in any gear.
Brake lights would be a separate problem. Deal with one at a time. CP gave good advise on how to start with that one.
Good luck on your troubleshooting.  :drinkingbud:
"Some guys think that having a better car makes them better than other guys, and those guys are right." -Top Gear

E-Bodies Cuda Challenger Message Forum

xx in some advice needed in Electrical & Audio
Re: some advice needed
« Reply #2 on: October 11, 2018, 09:39:13 AM »

Offline HP_Cuda

  • Roast em if ya got em
  • Trade Count: (1)
  • Six Pack
  • ****
  • Location: Western US
  • index in some advice needed in Electrical & Audio
  • Posts: 1968
  • Credits: 7580
  • Keep the rubber side down
    • Share Post
xx in some advice needed in Electrical & Audio
Re: some advice needed
« Reply #3 on: October 11, 2018, 09:42:58 AM »

The correct NSS has a nice washer on it to prevent leaking.
1970 Cuda Yellow 440 4 speed (Sold)
1970 Cuda clone 440 4 speed FJ5
1975 Dodge Power Wagon W200

Offline Plumcrazy72

  • Trade Count: (0)
  • Leaning Tower of Power
  • *
  • Location: Milverton
  • index in some advice needed in Electrical & Audio
  • Posts: 100
  • Credits: 850
    • Share Post
xx in some advice needed in Electrical & Audio
Re: some advice needed
« Reply #4 on: October 11, 2018, 10:20:57 AM »
If you went through 8 NSS switches I would start to suspect the lever in the transmission. Did the ones that leaked function properly otherwise? If they did then trans lever would be fine. There are two different length NSS switches out there, take a look at your collection and see if they are all the same. Then I would bench test the switch. Centre pin should have continuity to the 'nub' on the side of the switch that goes into the trans. The outer two pins should have continuity when the switch is activated (depressed). When you find one that checks out electrically, Install in the trans and check that the centre pin has continuity to the case of the trans when in park or neutral. If it doesn't, maybe something is in the way of screwing the switch in all the way? Maybe two or three gaskets?
For the reverse lights, put it in reverse and see if the outer pins have continuity. If you do, the switch /trans is ok and the issue is in the wiring to the reverse lights, or power to the switch for the reverse lights.
If you don't have continuity, and it bench tested ok, it is a matter of switch seating depth, or the plastic shroud may have broken in the trans - which would give the car the ability to start in any gear.
Brake lights would be a separate problem. Deal with one at a time. CP gave good advise on how to start with that one.
Good luck on your troubleshooting.  :drinkingbud:

 I had one brand i got from classic industries that worked as it should, reverse lights came on, would only start in neutral and park. The bad part of them is they leaked, not from where the rubber washer seals when tightened into the trans but it leaked between the center rubber part (that has the 3 pins) and the outer metal section (that has the threads) Another brand i have tried is just a little bit (like one-two threads approx.) shorter than the original, it only allows to be started in neutral and park but does not turn reverse lights on. All units check out ok when bench testing. I did not bench test the last one i got that was an original NSS as i was told it would work. After putting it in i now realize i should have checked it, as nothing worked and i believe caused a short

Offline Plumcrazy72

  • Trade Count: (0)
  • Leaning Tower of Power
  • *
  • Location: Milverton
  • index in some advice needed in Electrical & Audio
  • Posts: 100
  • Credits: 850
    • Share Post
xx in some advice needed in Electrical & Audio
Re: some advice needed
« Reply #5 on: October 11, 2018, 10:24:54 AM »
You have separate flashers for 4 way & turn signal so it is possible , but that will nto affect the brake lights .
the brake lights could be a bad turn signal switch or a bad brake light switch , you can trace power through the brake light switch up to the column  . Often if up put pressure toward you on the turn signal arm it may connect & work if so the problem for brake & Turn is in the TS switch
I will test this out tonight after work. Would this be caused by a short in a NSS? I know i had blinkers on my way to where i used the hoist, and i know i had break lights when i parked it the previous time because i can see them when backing upto the wall in my shop. Thanks for the help, appreciate it.

Online 7212Mopar

  • Trade Count: (0)
  • Big Block
  • ***
  • Location: Northern California
  • index in some advice needed in Electrical & Audio
  • Posts: 300
  • Credits: 2820
    • Share Post
xx in some advice needed in Electrical & Audio
Re: some advice needed
« Reply #6 on: October 11, 2018, 12:39:43 PM »
Manual or Auto trans? What I had done on a auto below.

https://forum.e-bodies.org/electrical-and-audio/11/neutral-safety-switch/5460/
1973 Challenger Rallye, 416 AT
2012 Challenger SRT8 6 speed Yellow Jacket

E-Bodies Cuda Challenger Message Forum

xx in some advice needed in Electrical & Audio
Re: some advice needed
« Reply #6 on: October 11, 2018, 12:39:43 PM »

Offline Plumcrazy72

  • Trade Count: (0)
  • Leaning Tower of Power
  • *
  • Location: Milverton
  • index in some advice needed in Electrical & Audio
  • Posts: 100
  • Credits: 850
    • Share Post
xx in some advice needed in Electrical & Audio
Re: some advice needed
« Reply #7 on: October 11, 2018, 02:33:56 PM »
Manual or Auto trans? What I had done on a auto below.

https://forum.e-bodies.org/electrical-and-audio/11/neutral-safety-switch/5460/
Auto trans

Sent from my SM-G390W using Tapatalk


Offline Plumcrazy72

  • Trade Count: (0)
  • Leaning Tower of Power
  • *
  • Location: Milverton
  • index in some advice needed in Electrical & Audio
  • Posts: 100
  • Credits: 850
    • Share Post
xx in some advice needed in Electrical & Audio
Re: some advice needed
« Reply #8 on: October 11, 2018, 03:30:47 PM »
From the TS wiring harness what colour is the blinkers at the connector? I have resolved my brake light issue just need to figure the turn signals now. Also is this the turn signal relay? 96705e441ff214f69731c8ef34d4bdb3 in some advice needed in Electrical & Audio0b5c3e8ea09995b41d59587f84a221d8 in some advice needed in Electrical & Audio

Sent from my SM-G390W using Tapatalk


Offline Rich G.

  • Trade Count: (1)
  • Big Block
  • ***
  • Location: Piscataway , NJ
  • Posts: 381
  • Credits: 1100
    • Share Post
xx in some advice needed in Electrical & Audio
Re: some advice needed
« Reply #9 on: October 11, 2018, 06:22:37 PM »
Thatís not it. Itís a 2 prong.  Thereís 2 flashers , one for the 4 ways and one for the turn signals . Both the same. 2 different locations . The turn signal one is usually behind the ash tray.

Offline anlauto

  • Trade Count: (6)
  • E-Body Wizard
  • *****
  • Location: Georgetown Ontario Canada
  • index in some advice needed in Electrical & Audio
  • Posts: 7285
  • Credits: 18760
  • Life is like a box of chocolates....
    • Share Post
    • www_sm in some advice needed in Electrical & Audio
xx in some advice needed in Electrical & Audio
Re: some advice needed
« Reply #10 on: October 11, 2018, 06:48:54 PM »
That's the timer delay for the A01 light group option.
I've taught you everything you know....but I haven't taught you everything I know....
Check out my web site ....  Alan Gallant Automotive Restoration

E-Bodies Cuda Challenger Message Forum

xx in some advice needed in Electrical & Audio
Re: some advice needed
« Reply #10 on: October 11, 2018, 06:48:54 PM »

Offline dodj

  • Trade Count: (1)
  • Big Block
  • ***
  • Location: Thunder Bay
  • index in some advice needed in Electrical & Audio
  • Posts: 649
  • Credits: 3070
    • Share Post
xx in some advice needed in Electrical & Audio
Re: some advice needed
« Reply #11 on: October 11, 2018, 07:10:43 PM »
Thatís not it. Itís a 2 prong.  Thereís 2 flashers , one for the 4 ways and one for the turn signals . Both the same. 2 different locations . The turn signal one is usually behind the ash tray.
the other flasher is mounted above the steering column.

Offline Plumcrazy72

  • Trade Count: (0)
  • Leaning Tower of Power
  • *
  • Location: Milverton
  • index in some advice needed in Electrical & Audio
  • Posts: 100
  • Credits: 850
    • Share Post
xx in some advice needed in Electrical & Audio
Re: some advice needed
« Reply #12 on: October 11, 2018, 08:29:30 PM »
That's the timer delay for the A01 light group option.
Okay thanks. Thought that was likely it.

Sent from my SM-G390W using Tapatalk


Offline Plumcrazy72

  • Trade Count: (0)
  • Leaning Tower of Power
  • *
  • Location: Milverton
  • index in some advice needed in Electrical & Audio
  • Posts: 100
  • Credits: 850
    • Share Post
xx in some advice needed in Electrical & Audio
Re: some advice needed
« Reply #13 on: October 11, 2018, 08:30:06 PM »
I will check both locations thanks guys

Sent from my SM-G390W using Tapatalk


Offline Chryco Psycho

  • Global Moderator
  • Trade Count: (0)
  • E-Body Wizard
  • *****
  • Location: Coronado Panama
  • index in some advice needed in Electrical & Audio
  • Posts: 6617
  • Credits: 15260
  • Challenger ... You'll wish you hadn't !!
    • Share Post
xx in some advice needed in Electrical & Audio
Re: some advice needed
« Reply #14 on: October 11, 2018, 09:16:18 PM »
You have separate flashers for 4 way & turn signal so it is possible , but that will nto affect the brake lights .
the brake lights could be a bad turn signal switch or a bad brake light switch , you can trace power through the brake light switch up to the column  . Often if up put pressure toward you on the turn signal arm it may connect & work if so the problem for brake & Turn is in the TS switch
I will test this out tonight after work. Would this be caused by a short in a NSS? I know i had blinkers on my way to where i used the hoist, and i know i had break lights when i parked it the previous time because i can see them when backing upto the wall in my shop. Thanks for the help, appreciate it.
The Nss has no effect on brake or turn signal lights

E-Bodies Cuda Challenger Message Forum

xx in some advice needed in Electrical & Audio
Re: some advice needed
« Reply #14 on: October 11, 2018, 09:16:18 PM »

Tags:

Share via delicious Share via digg Share via facebook Share via linkedin Share via pinterest Share via reddit Share via stumble Share via tumblr Share via twitter Share via whatsapp

xx
Advice needed detailing my Challenger for show?

Started by JH27N0B

19 Replies
459 Views
Last post November 14, 2018, 06:34:40 PM
by JH27N0B
xx
Transmission advice

Started by booyaballer

17 Replies
1156 Views
Last post November 02, 2017, 06:46:56 PM
by Topcat
xx
Advice Please On A Milodon Oil Pan

Started by Wedg2Go

1 Replies
321 Views
Last post July 07, 2017, 07:35:45 AM
by 1 Wild R/T
xx
New member here looking for advice

Started by superdave

25 Replies
1018 Views
Last post January 08, 2018, 10:20:44 AM
by Chryco Psycho
xx
Brake Advice

Started by rebelyell

9 Replies
309 Views
Last post October 23, 2018, 06:57:22 AM
by RUNCHARGER